Right Now, I’m Dial-Up Boy

Last night, around 17:30, my DSL died. I had been using it up until 16:30, and everything was fine. But later, while I had gone out for a bit, it went Tango Uniform. I tried to get it back up before I had to go bowling, but nothing worked. I hoped it would come back up by itself while I was gone, but when I got home around 22:30, it was still dead.

I tried some diagnostics, but couldn’t get it going again. So I called BellSouth to see what was up. I ended up speaking to a guy called “Dave” (I doubt that was his real name, given his accent), until 01:30 this morning. It was not a fun discussion. I was getting a solid DSL light on the DSL modem, which meant that there was a hardware connection between me and the BellSouth network, but the failure was happening when the PPPoE handler in my router tried to login. It just didn’t work. I explained this to “Dave” and then the fun began.

When I mentioned that I had a router, “Dave” asked me the manufacturer. I told him it was a SonicWall, and he immediately told me that I would have to contact SonicWall for support. I told him there was no way this was a problem with the router. This setup had been working flawlessly for over a year. All signs pointed to a problem on their end, but he adamantly denied there was anything wrong over there. I humored him and hooked the DSL modem directly to my Mac, to take the router completely out of the picture. Same results. He did say that he had “reset a few ports” on his end (whatever that meant), but it still didn’t work. “Dave” finally “concluded” that the modem was malfunctioning, and they would have to send me another. Never-mind the fact that the modem’s self-test showed it was OK, that both ports were working, that I had hardware sync to the CO. No, the problem must be the modem. And so, I will be stuck without DSL for 2 or 3 days.

Now, here’s what’s interesting about this whole absurd affair. Three days ago, I put in an order with BellSouth (part of the “New” AT&T) to upgrade my DSL from 3Mbps to 6Mbps. The conversion was supposed to be complete on 01/24, but according to “Dave” it was complete on 01/22. Gee, why does that date sound familiar? Oh, yeah. It’s the same date that my DSL died. I put this question to “Dave”: Doesn’t it seem a bit suspicious to you that my modem up and died on the very same day that you say changes were made to my service on your end? He stumbled over that for a second, and then “confirmed” that the modem was the cause of the problem, and did I want them to ship me a new modem? When I placed the order for the speed upgrade, I asked the person directly: Do I need to switch out the modem and/or will there be any sort of outage for the upgrade? She told me specifically: No, the modem is fine, and you won’t see any outage.

So, where do we stand? I suspect that the modem I had was not capable of handling the increased speed. I can’t verify that, but that’s what I think. Rather than admit that they screwed me by not telling me there would be an outage until I swapped out modems, they cover it up with a story that my modem has just mysteriously died, and they would send me another. For free. Yes, for free. I could be completely wrong on this one. Perhaps when the new one gets here, I’ll hook it up and be back in DSL bliss, but my gut tells me that won’t be the case. I had hoped to test my theory today, by going to Best Buy and buying a 3rd-party DSL modem, but guess what. You can’t. You can buy cable modems all day long, but no DSL modems.

So, here I sit, dressed as Dial-Up Boy, the inferior sidekick to High-Speed DSL Man. My shiny Mac Pro doesn’t have a modem… but my iBook does. So I ran a phone line to the iBook and got a regular PPP dial-up connection to BellSouth established. I then shared the connection, and after figuring out what I needed to do to get routing working, I now have full Internet access from my Mac Pro, via the iBook’s modem connection. I did have some routing problems, but my friend reminded me that I have two Ethernet ports on the Mac Pro, so I hooked one cable directly between the Pro and the iBook, and the other from the Pro to the router. Now packets bound for my LAN go out en1 and packets bound for the Internet go out en0 and get routed through the iBook, to it’s modem, then to BellSouth-land, and then out into the wild. Slowly. But they do get there. Very, very, slowly.

01/24/2007 17:14 Update: The replacement modem arrived today around 16:00. I quickly unpacked it and hooked it directly to my Mac, just to leave the router out of the equation for the moment. As I (mostly) expected, the new modem did exactly what the old one did: not connect. So, I called tech support, this time getting a very friendly woman, supposedly called “Deborah.” Within about 2 minutes, she had determined that there was a problem on their end. She then gasp! consulted a line engineer. Between the two of them, within about 4 minutes they had determined that my line had not been provisioned properly when they “upgraded” me to 6Mbps. They flipped some switches on their said and then BLAMMO! full-speed, 6Mbps DSL, baby!

I knew that I needed to put the modem into “bridge” mode, so that my router could handle the PPPoE stuff, but I wasn’t sure how to bridge it. She walked me through it and after a restart of the modem, I moved my cables around and now all is right with the world.

What this means, of course, is if “Dave” had consulted a line engineer two nights ago, I might not have had to endure two days of dial-up hell. Thus, “Deborah” gets an A+ for support, while “Dave” gets a D.

Advertisements

3 thoughts on “Right Now, I’m Dial-Up Boy

  1. I’d be shocked if the modem couldn’t handle the 6mbps. My DSL modem is pretty old and it handles 6mbps down just fine. They screwed up something on their end.

  2. You’re giving “Dave” too much credit. He not only didn’t help you, but made you jump through hoops that were useless and unnecessary. He also delayed the actual resolution to your problem. I’d say that deserves a failing grade. If he simply hung up on you and made you call back in, he would have been more helpful than he was.

  3. Wow! Exactly the same process I went through a month ago in San Bruno, CA. Upgrade, then failures just like you described. And the same ultimate repair. The on-line technicians had a script that they refused to deviate from, even if the previous tech and I had done it many (too many) times before. And the problem was a failure to wire the outside line properly (found by a sharp female engineer they sent out). And every call they had to remind me I would have to PAY if the failure was found to be in my house — for a service they were billing me for. grrrrr. Since the problem was resolved, everything has worked flawlessly.

Comments are closed.