ULDebunk Now Works With Firefox 0.10 and Thunderbird 0.8

I’ve just updated ULDebunk to work with the latest versions of Firefox and Thunderbird. Get it while it’s hot!

Advertisements